
Preface

ASM (Aquifer Simulation Model) is a complete implementation of a 2-D groundwater model for
use on a PC under MS-Windows(tm). It was originally developed as a tool for the education of
students in the hydrogeology, civil and environmental engineering. The first version of ASM was
published in 1989 and ran under MS-DOS. 

Since that time ASM has been continually enhanced and improved.

This users manual documents the latest and most powerful version 6.0 of ASM which runs under
the Microsoft Windows(tm) operting system. The most notable change in this version is the use
of a new, friendly graphical user interface which replaces the character oriented interfaces of
previous versions.

At the same time, ASM-6.0 allows the manipulation of larger model grids which makes it suitable
for prefessional use. It is hoped that this very user-friendly implementation of a groundwater
model on Windows(tm) PCs will lower the threshold which inhibits the widespread use of
computer based groundwater models. Its ease of use allows getting acquainted with the properties
and peculiarities of groundwater flow and transport paths by experimenting with the models by
changing relevant parameters.

Readers unfamiliar with the theoretical background of groundwater hydraulics and groundwater
modelling are referred to the textbooks listed in the references section of this manual
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1. Introduction

Aquifer Simulation Model for Windows (ASMWIN) implements a complete two-dimensional
groundwater flow and transport model. This new model is a strongly enhanced Windows-version
of ASM 5.0, which  runs under MS-DOS (Kinzelbach & Rausch, 1995). ASMWIN comes with
a professional graphical user-interface, a finite-difference flow model, a tool for the automatic
calibration of a flow model, a particle tracking model, a random walk transport model, a finite-
difference transport model and several other useful modeling tools. 

The graphical user-interface allows you to create and simulate models with ease and fun. It can
handle models with up to 150 × 150 cells and 1000 time periods (pumping intervals). ASMWIN
can create contour maps or solid fill plots of input data and simulation results. Solid Fill can utilize
the full range of RGB colors to fill cells with different values. Contours can be added to these
plots. Report-quality graphics may be saved to a wide variety of file formats, including SURFER,
DXF, HPGL and BMP (Windows Bitmap).

The discretized flow equations are solved by the preconditioned conjugate gradient (PCG)
method (module ASMSIM1) with the choice of diagonal and Cholesky preconditioning. For
steady state flow fields, an automatic model calibration procedure using the Marquardt-Levenberg
algorithm is available in the module ASMOPTI.

The particle tracking module ASMPATH offers several velocity interpolation methods and uses
Euler-Integration to compute flow paths and travel times. ASMPATH allows you to perform
particle tracking with just a few mouse clicks. Both forward and backward particle tracking
schemes are feasible for steady-state and transient flow fields. ASMPATH calculates and shows
pathlines or flowlines and travel time marks simultaneously. It provides various on-screen
graphical options including head contours, drawdown contours, and velocity vectors.

Two transport simulation modules are available. The first uses a finite-difference scheme (Module
ASMT2SIM) while the second uses a random-walk method based on Ito-Fokker-Planck theory
(Module ASMWALK).

The modeling tools include a Result Extractor, a Field Interpolator, a Field Generator, a
Water Budget Calculator and a Graph Viewer. 

The Result Extractor allows the user to extract simulation results from any period to a spread
sheet. You can then view the results or save them in ASCII or SURFER-compatible data files.
Simulation results include hydraulic heads, drawdowns, Darcy velocities, leakage terms and
concentrations.

The Water Budget Calculator not only calculates the budget of user-specified zones but also
the exchange of flows between such zones. This facility is very useful in many practical cases. It
allows the user to determine the flow through a particular boundary.  

The Field Generator generates fields with heterogeneously distributed transmissivity or hydraulic
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conductivity values. It allows the user to statistically simulate effects and influences of unknown
small-scale heterogeneities. The Field Generator is based on Mejía's (1974) algorithm. 

The Graph Viewer displays temporal development curves of simulation results including
hydraulic heads, drawdowns and concentrations. 

System Requirements

Hardware
Personal computer running Microsoft Windows 3.1x, Windows 95 or Windows NT
8 MB of available memory (16MB or more are recommended)
A CD-ROM drive and a hard disk.
VGA or higher-resolution monitor
Microsoft Mouse or compatible pointing device

Software
A FORTRAN compiler is required if you intend to modify and compile the modules ASMSIM1,
ASMT2SIM, ASMWINMC and ASMOPTI.

Setting Up ASMWIN

You install ASMWIN on your computer using the program SETUP.EXE contained on the CD.
The setup program installs ASMWIN and other program components from the distribution CD
to your hard disk.

Note that you cannot simply copy files to your hard disk and run ASMWIN. You must use the
setup program to decompress and install the files in the appropriate directories.

After installing ASMWIN, you should add the following entries to the configuration file
(CONFIG.SYS or CONFIG.NT) and reboot your computer.

For DOS/Windows 3.1x:
 Configuration file: C:\CONFIG.SYS

FILES=80
DEVICE=C:\DOS\ANSI.SYS

For Windows 95
Configuration file: C:\CONFIG.SYS
FILES=80
DEVICE=C:\WINDOWS\COMMAND\ANSI.SYS
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For Windows NT
Configuration file: C:\WINNT\SYSTEM32\CONFIG.NT
FILES=80
DEVICE=C:\WINNT\SYSTEM32\ANSI.SYS

Note that you should change the paths indicated above (C:\DOS, C:\WINDOWS or C:\WINNT)
if you have installed the operating systems in other directories.

Online Help

The online help system references nearly all aspects of ASMWIN. You can access Help through
the Help menu Contents command, by searching for specific topics with the Help Search tool, or
by pressing F1 to get context sensitive Help on the ASMWIN modeling environment.

Help Search
The fastest way to find a particular topic in Help is to use the Search dialog box. To display the
Search dialog box, either choose Search from the Help menu or click the Search button on any
Help topic screen.

To search Help
1. From the Help menu, choose Search. (You can also click the Search button from any Help

topic window).
2. In the Search dialog box, type a word, or select one from the list by scrolling up or down.

Press ENTER or choose Show Topics to display a list of topics related to the word you
specified.

3. Select a topic and press ENTER or choose Go To to view the topic.

Context-Sensitive Help 
Many parts of the ASMWIN Help facility are context-sensitive. Context-sensitive means you can
access help on any part of ASMWIN directly by clicking the Help button.

Updates

Today the development of groundwater modeling techniques is progressing very rapidly, and a
groundwater model must periodically be updated and expanded. For updates of ASMWIN and
our other software you may access the following web-pages on the Internet:

http://ourworld.compuserve.com/homepages/W_H_Chiang/
http://www.baum.ethz.ch./ihw/soft/welcome.html
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Fig. 2.1 Configuration of the sample problem

2. Your First Groundwater Model with ASMWIN

It takes just a few minutes to build your first groundwater flow model with ASMWIN. First,
create a new groundwater model by choosing New Model from the File menu. Next, determine
the size of the model grid by selecting Mesh Size from the Grid menu. Then, specify the
geometry of the model and set the model parameters, such as hydraulic conductivity, effective
porosity etc.. Finally, perform the flow simulation by choosing Flow Simulation from the Run
menu. After completing the flow simulation, you can use the modeling tools provided by
ASMWIN to view the results, to calculate water bugdets of particular zones, or graphically
display the results, such as head contours. You can also use ASMPATH to calculate and save
pathlines or use the Random Walk or finite difference transport model to simulate transport
processes.

This chapter provides an overview of the modeling process with ASMWIN, describes the basic
skills you need to use ASMWIN, and takes you step by step through the sample model. A
complete reference of all menus and dialog boxes in ASMWIN is contained in Chapter 3. The
transport models and the modeling tools are described in Chapter 4 and Chapter 5, respectively.

The Sample Problem

The configuration of the sample problem is shown in Fig. 2.1. An aquifer is bounded by no-flow
boundaries on the North and South sides. The West and East sides are constant-head boundaries.
The hydraulic heads on the west and east boundaries are 9 m and 8 m above reference level,
respectively.

The aquifer is assumed to be isotropic, unconfined with a hydraulic conductivity of 0.0005 m/s.
The effective porosity is 15 percent. The elevations of the top and bottom of the aquifer are 10
m and -3 m, respectively. A contaminated area lies next to its western boundary. The task is to
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isolate the contaminated area using a pumping well located next to the eastern boundary. 

A numerical model has to be developed for this site to calculate the required pumping rate of the
well. The pumping rate must be high enough, so that the contaminated area lies within the
capture zone of the pumping well. We will use ASMWIN to construct the numerical model and
use ASMPATH to compute the capture zone. Based on the calculated groundwater flow field,
we will use ASMWALK (Random Walk method) and ASMT2SIM (finite-difference scheme) to
simulate the contaminant transport. Finally, we will show how to use ASMOPTI to calibrate the
model automatically. 

Starting ASMWIN 

The ASMWIN Setup program automatically creates a new program group and new program
items for Aquifer Simulation Model in Windows. You are ready to start ASMWIN from
Windows by clicking the ASMWIN icon.

<< To start ASMWIN from Windows
! double-click the Aquifer Simulation Model icon.

When you start ASMWIN, you see the interface of ASMWIN with a Menu bar and a tool bar.
The tool bar contains an Open Model icon, you can click this icon to open a model.

2.1 Run a Steady-State Flow Simulation

Four main steps must be performed in a steady-state flow simulation:
1. Create a new model
2. Assign model data
3. Perform the flow simulation
4. Check simulation results and produce output.

Step 1.: Create a New Model 
The first step in running a flow simulation is to create a new model.

<< To create a flow model
1. choose New Model from the File menu. A New Model dialog box appears. Select a

directory for the model data, such as C:\ASMWIN\EXAMPLES\SAMPLE, and type the file
name SAMPLE for the sample model. An ASMWIN model must always have the file
extension ASM. It is recommended to save every model in a separate directory, where the
model and its output data will be kept. This also allows to run several models simultaneously
(multitasking). If a desired directory for saving a new model is not available, use the
Windows File Manager, Explorer or other utilities to create the directory.

2. Click OK.
ASMWIN takes only a few seconds to create the new model. The name of the new model is
shown in the title bar. 
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Fig. 2.2 Spatial discretization of an aquifer system and the cell indices

Step 2.: Assign Model Data
The second step in running a flow simulation is to generate the model grid (mesh), specify
boundary conditions, and assign model parameters to the model grid. In ASMWIN, every aquifer
system is represented by a discretized domain consisting of an array of nodes and associated
finite difference cells. Fig. 2.2 shows a spatial discretization of an aquifer system with a mesh of
cells and nodes at which hydraulic heads are calculated. The nodal grid forms the framework of
the numerical model. The thicknesses of each model cell and the width of each column and row
may be variable. The locations of cells are described in terms of columns and rows. ASMWIN
uses an index notation [I, J] for locating the cells. For example, the cell located in the 5th column
and 8th row is denoted by [5, 8]. 

<< To generate the model grid
1. Choose Mesh Size from the Grid menu. 

The Model Dimension dialog box appears (Fig. 2.3)
2. Enter 30 for the number of columns and rows, and 20 for the size of columns and rows.
3. Click OK.

ASMWIN changes the pull-down menus and shows the generated model grid (Fig. 2.4).
ASMWIN allows you to shift or rotate the model grid, change the width of each model
column or row, or to add/delete model columns or rows. For our sample problem, you do not
need to modify the model grid. See section 3.1 for more information about the Grid Editor.

4. Choose Leave Editor from the File menu or click the Leave Editor icon 

The next step is to specify the type of aquifer.

<< To assign the type of aquifer
1. Choose Aquifer Type from the Grid menu.

An Aquifer Options dialog box appears.
2. Select Unconfined as the aquifer type.  
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Fig. 2.3 The Model Dimension dialog box

Fig. 2.4 The generated model grid

Fig. 2.5 The Aquifer Options dialog box

3. Type 1 for the anisotropy factor.
4. Click OK.
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Now, you must specify the boundary conditions of the flow model. You specify a code for each
model cell which indicates whether (1) the hydraulic head is computed  (active variable-head cell
or active cell), (2) the hydraulic head is kept fixed at a given value (constant-head cell), or (3) no
flow takes place within the cell (inactive cell). It is suggested to use 1 for an active cell, -1 for a
constant-head cell, and 0 for an inactive cell. For the sample problem, we need to assign -1 to the
cells on the west and east boundaries and 1 to all other cells.  

<< To assign the boundary condition to the flow model
1. Choose Boundary Conditions << Flow Model from the Grid menu.

ASMWIN displays a plan view of the model grid (Fig. 2.6). The grid cursor is located in the
cell [1, 1], i.e., the upper-left cell. The value of the current cell is shown at the bottom of the
status bar. The default value is 1. The grid cursor can be moved horizontally by using the
arrow keys or by clicking the mouse on the desired position. 

Note that a DXF-map is loaded by using the Maps Options. See Chapter 3 for details.

2. Pressing the right mouse button, ASMWIN shows a Cell Value dialog box. 
3. Type -1 in the dialog box, then click OK.

The upper-left cell of the model has been specified to be a constant-head cell.

4. Now turn on duplication by clicking the duplication icon  . 
The small box on the lower-right corner of this icon will be highlighted. The current cell value
will be duplicated to all cells passed over by the grid cursor, if it is moved while duplication
is on. You can turn off duplication by clicking the duplication icon again. 

5. Move the grid cursor from the upper-left cell [1, 1] to the lower-left cell  [1, 30] of the model
grid. 
The value of -1 is duplicated to all cells on the west side of the model.

6. Move the grid cursor to the upper-right cell [30, 1] by a mouse click. 
7. Move the grid cursor from the upper-right cell [30, 1] to the lower-right cell [30, 30]. 

The value of -1 is duplicated to all cells on the east side of the model.

8. Choose Leave Editor from the File menu or click the Leave Editor icon 

The next step is to specify the geometry of the model. 
<< To specify the elevation of the top of the aquifer
1. Choose Aquifer Top from the Grid menu.

ASMWIN shows the model grid. 
2. Choose Matrix<<Reset from the Value menu (or press Ctrl+R).

A Reset Matrix dialog box appears.
3. Enter 10 into the dialog box, then click OK.

The elevation of the top of the aquifer is set to 10.

4. Choose Leave Editor from the File menu or click the Leave Editor icon 
5. An externally prepared matrix can be imported by means of Matrix Browse (refer to chapter

3.3.7).
6. For better orientation a map overlay prepared externally can be displayed on top of the model

grid (refer to chapter 3.3.8).
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Fig. 2.6 Top view of the model grid. Model data are assigned to each cell.

<< To specify the elevation of the bottom of the aquifer
1. Select Aquifer Bottom from the Grid menu.
2. Repeat the same procedure as described above to set the bottom of the aquifer to -3.

3. Choose Leave Editor from the File menu or click the Leave Editor icon 

Now, we are going to specify the temporal and spatial parameters of the model. The spatial
paramters dor the sample problem include the initial hydraulic head, hydraulic conductivity and
effective porosity.

<< To specify temporal parameters 
1. Choose Time from the Parameters menu.

A Time Parameters dialog box appears. The temporal parameters include the time unit and
the numbers of stress periods and time steps. In ASMWIN, the simulation time is divided into
stress periods - i.e., time intervals during which all external excitations or stresses are
constant - which are, in turn, divided into time steps. The length of a stress period is not
relevant to a steady state flow simulation.

2. Click OK to accept the default values.

<< To specify the initial hydraulic head
1. Choose Starting Values<<Hydraulic Heads from the Parameters menu.

ASMWIN displays the model grid. Now, you can specify the initial hydraulic head for each
model cell. The initial hydraulic head at a constant-head boundary will be kept constant
during the flow simulation. The other heads are starting values in the time-varying simulation
or first guesses for the iterative solver in a steady-state simulation. Here we set all values to
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8 first and then correct the values on the west side by overwriting them with a value of 9.
2. Choose Matrix<<Reset from the Value menu (or press Ctrl+R) and enter 8 in the dialog box,

then click OK.
3. Move the grid cursor to the upper-left model cell. 
4. Press the right mouse button and enter 9 into the Cell Value dialog box, then click OK.

5. Now turn on duplication by clicking the duplication icon  . 
The small box on the lower-right corner of this icon will be highlighted. The current cell value
will be duplicated to all cells passed over by the grid cursor, if it is moved while duplication
is on.

6. Move the grid cursor from the upper-left cell to the lower-left cell of the model grid. 
The value of 9 is duplicated to all cells on the west side of the model.

7. Choose Leave Editor from the File menu or click the Leave Editor icon 

<< To specify the hydraulic conductivity
1. Choose Hydraulic Conductivity from the Parameters menu.
2. Choose Matrix<<Reset from the Value menu (or press Ctrl+R) and type 0.0005 in the dialog

box, then click OK.

3. Choose Leave Editor from the File menu or click the Leave Editor icon 

<< To specify the effective porosity
1. Choose Effective Porosity from the Parameters menu.
2. Choose Matrix<<Reset from the Value menu (or press Ctrl+R), enter 0.15, then click OK.

3. Choose Leave Editor from the File menu or click the Leave Editor icon 

The last step before the actual flow simulation is to specify the location of the pumping well and
its pumping rate. In ASMWIN, an injection or pumping well is represented by a node (or a cell).
The user specifies an injection or pumping rate for each node. It is implicitly assumed that the
well penetrates the full thickness of the aquifer. As we do not know the pumping rate required
for capturing the contaminated area shown in Fig. 2.1, we will try a pumping rate of 0.002 m /s.3

<< To specify the pumping well and the pumping rate
1. Choose Wells from the Packages menu.
2. Move the grid cursor to the cell [25, 15]
3. Press the right mouse button and type -0.002, then click OK. Note that a negative value is

used to indicate a pumping well and a positive value to indicate an injection well.

4. Choose Leave Editor from the File menu or click the Leave Editor icon   

Step 3.: Perform the Flow Simulation
Now everything is ready to run the flow simulation. 

<< To perform the flow simulation
1. Select Run menu and choose Flow Simulation.

The Flow Simulation dialog box appears (Fig. 2.7). It allows the user to specify the
convergence criteria for the iterative equation solver. Whether the accuracy of a simulation
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Fig. 2.7 The Flow Simulation dialog box

is sufficient can checked with the water balance. 
2. Click OK to start the flow computation.

Prior to running the flow simulation, ASMWIN will use user-specified data to generate an
input file for the simulation program ASMSIM1.EXE. In addition, ASMWIN creates a batch
file ASMSIM.BAT in the model directory. After having generated the files, ASMWIN
automatically opens a DOS-box and runs ASMSIM.BAT in the box.

Step 4.: Check Simulation Results and Produce Output
After a flow simulation is completed successfully, ASMWIN saves the results in files
path\filename.xxx. Where path is the directory in which your model data are saved, filename is
the name of your model and xxx is an extension for the stress period number.  

Note that there is one file for each stress period with extensions ".1" through ".n". These files contain
among other data the spatial distribution of computed piezometer heads and Darcy velocities at the end
of a pumping or time period. For a steady state computation only one result file with extension ".1" is
created. These files are input files for the particle tracking model ASMPATH, the Random Walk
transport model ASMWALK, the finite difference transport model, the Water Budget Calculator and the
Graph Viewer.

To check the simulation results, ASMWIN provides a Water Budget Calculator, which
computes water budgets for the entire model, user-specified subregions, and flows between
adjacent subregions. A water budget provides an indication of the overall quality of the numerical
solution. In numerical solution techniques, the system of equations solved by a model actually
consists of a flow continuity statement for each model cell. Continuity should also exist for the
total flows into and out of the entire model or a sub-region. This means that the difference
between total inflow and total outflow should equal the total change in storage or be equal to
zero for a steady-state flow field.

In addition to the Water Budget Calculator, ASMWIN provides various possibilities for
checking simulation results and creating graphical output. Using the Results Extractor,
simulation results of stress periods can be read from the result files and saved in ASCII Matrix
files. An ASCII Matrix file contains a value for each model cell. The format of the ASCII Matrix
file is described in Appendix 2. ASMWIN may also generate contour maps based on an ASCII
Matrix file. 

In the following, we will carry out the steps:
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Fig. 2.8 The Water Budget dialog box

(2.1)

1. Use the Water Budget Calculator to compute water budgets of  the entire model and
subregions, and check if the percent discrepancies of in- and outflows are acceptably small.

2. Use the Result Extractor to read and save the calculated hydraulic heads.
3. Generate contour maps based on the calculated hydraulic heads saved in step 2.
4. Create a  solid fill plot based on the calculated hydraulic heads saved in step 2 and add

contours to the plot. 
5. Use ASMPATH to produce pathlines and delineate the capture zone of the pumping well.

<< To calculate subregional water budgets
1. Choose Water Budget from the Tools menu.

The Water Budget dialog box appears (Fig. 2.8). Specify a file name for saving the
calculation results.

2. Click Zones.
A zone is a subregion of a model for which a water budget will be calculated. A zone is
indicated by a zone number ranging from 0 to 50. A zone number must be assigned to each
model cell. The zone number of 0 indicates that a cell is not associated with any zone. Follow
the steps 3 through 5 to assign the zone number 1 to the contaminated area and the zone
number 2 to the other area.

3. Choose Matrix<<Reset from the Value menu (or press Ctrl+R), type 2 in the dialog box, then
click OK.

4. Assign 1 to the cells in the contaminated area.

5. Choose Leave Editor from the File menu or click the Leave Editor icon 
6. Click Go in the Water Budget dialog box. 

ASMWIN calculates and saves the water budget in the specified file as shown in Table 2.1. The
units of flows are [L /T], where T is the time unit specified in the Time Parameters dialog box3

and L is the length unit. Flows are considered IN, if they are entering a zone. Flows between
subregions are given in a flow matrix. Water budgets are calculated for each zone and each
period. HORIZ. EXCHANGE gives the flows which flow horizontally across a zone's boundary.

The percent discrepancy is calculated by the equation (2.1)
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In this example, the percent discrepancies of in- and outflows for the model and each zone are
acceptably small. This means the model equations are correctly solved. 

---------------------------------------------------------

                 ASMWIN - WATER BUDGET                   

---------------------------------------------------------
FLOWS ARE CONSIDERED 'IN' IF THEY ARE ENTERING A SUBREGION
THE UNIT OF THE FLOWS IS [L^3/SECOND]

MODEL: C:\ASMWIN\EXAMPLE\SAMPLE.ASM
STEADY STATE SOLUTION

WATER BUDGET OF THE WHOLE MODEL DOMAIN

      FLOW TERM            IN           OUT        IN-OUT
        STORAGE  0.000000E+00  0.000000E+00  0.000000E+00
  CONSTANT HEAD  6.295397E-03  4.289134E-03  2.006263E-03
           WELL  0.000000E+00  2.000000E-03 -2.000000E-03
        LEAKAGE  0.000000E+00  0.000000E+00  0.000000E+00
  BOUNDARY FLOW  0.000000E+00  0.000000E+00  0.000000E+00
       RECHARGE  0.000000E+00  0.000000E+00  0.000000E+00
---------------------------------------------------------
            SUM  6.295397E-03  6.289135E-03  6.262213E-06
DISCREPANCY [%]          0.10

SUBREGIONAL WATER BUDGET

ZONE  1 
      FLOW TERM            IN           OUT        IN-OUT
        STORAGE  0.000000E+00  0.000000E+00  0.000000E+00
  CONSTANT HEAD  0.000000E+00  0.000000E+00  0.000000E+00
           WELL  0.000000E+00  0.000000E+00  0.000000E+00
        LEAKAGE  0.000000E+00  0.000000E+00  0.000000E+00
  BOUNDARY FLOW  0.000000E+00  0.000000E+00  0.000000E+00
       RECHARGE  0.000000E+00  0.000000E+00  0.000000E+00
HORIZ. EXCHANGE  1.496800E-03  1.497837E-03 -1.037028E-06
---------------------------------------------------------
            SUM  1.496800E-03  1.497837E-03 -1.037028E-06
DISCREPANCY [%]         -0.07

ZONE  2 
      FLOW TERM            IN           OUT        IN-OUT
        STORAGE  0.000000E+00  0.000000E+00  0.000000E+00
  CONSTANT HEAD  6.295397E-03  4.289134E-03  2.006263E-03
           WELL  0.000000E+00  2.000000E-03 -2.000000E-03
        LEAKAGE  0.000000E+00  0.000000E+00  0.000000E+00
  BOUNDARY FLOW  0.000000E+00  0.000000E+00  0.000000E+00
       RECHARGE  0.000000E+00  0.000000E+00  0.000000E+00
HORIZ. EXCHANGE  1.497837E-03  1.496800E-03  1.037028E-06
---------------------------------------------------------
            SUM  7.793234E-03  7.785934E-03  7.299241E-06
DISCREPANCY [%]          0.09

FLOW MATRIX:
Element (I,J) of the following matrix gives the flow rate from
zone I to zone J. Where I is the column index and J is the row index.

               1             2
------------------------------
 1  0.000000E+00  1.496800E-03
 2  1.497837E-03  0.000000E+00

Table 2.1 Output from the Water Budget Calculator
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Fig. 2.9 Result types and the Results Extractor dialog box.

<< To read and save the calculated hydraulic heads
1. Choose Result Extractor from the Tools menu.

The Result Extractor dialog box appears (Fig. 2.9). You can choose a result type from the
Result Type drop-down box. Then specify the stress period number from which the result
should be read. The spreadsheet displays a series of columns and rows. The intersection of a
row and column is a cell. Each cell of the spreadsheet is corresponding to a model cell. By
setting the Save Format option, the result can be optionally saved as an ASCII Matrix or a
SURFER data file format. 
Follow steps 2 through 6 to save the calculated hydraulic heads in the ASCII Matrix files
H1.DAT. 

2. Choose Hydraulic Head from the Result Type drop-down box. 
3. Type 1 for the Stress Period.
4. Click Read. 

Hydraulic heads of stress period 1 will be read and put into the spreadsheet. You can scroll
the spreadsheet by clicking on the scrolling bars next to the spreadsheet.

5. Click Save.
A Save Matrix As dialog box appears. Specify the file name H1.DAT and select a directory
in which H1.DAT should be saved. Click OK when ready.

6. Click the Cancel button to close the dialog box.

<< To generate contour maps of the calculated heads
1. Choose Recycle from the Tools menu

Data specified in Recycle will not be used by any simulation program. We can use Recycle
to save temporary data or to display simulation results graphically.

2. Choose Matrix<<Browse from the Value menu (or Press Ctrl+B). 
The Browse Matrix dialog box appears (Fig. 2.10). Each cell of the spreadsheet
corresponds to a model cell. You can load an ASCII Matrix file into the spreadsheet or save
the spreadsheet in an ASCII Matrix file by clicking Load or Save. Alternatively you could
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Fig. 2.10 The Browse Matrix dialog box with the cell values in the spreadsheet 

call the results extractor, read the head results again, and apply them to the Recycle matrix.
3. Click Load.

The Load Matrix dialog box appears (Fig. 2.11). 

4. Click   and select file H1.DAT to be loaded (H1.DAT was saved earlier by the Results
Extractor). Click OK when ready.
H1.DAT is loaded and put into the spreadsheet. 

5. In the Browse Matrix dialog box, click OK.
The Browse Matrix dialog box will be closed.

6. Choose Environment from the Options menu (or Press Ctrl+E). 
The Environment Options dialog box appears (Fig. 2.12). It allows the user to modify the
appearance and position of the model grid.

7. In the Environment Options dialog box, check the Visible check box of the Contours
group, click the color button next to the Visible check box to select an appearance color for
the contours. Note that ASMWIN will clear the Visible check box when you leave the
Editor.

8.. In the Environment Options dialog box, Click OK.
ASMWIN will redraw the model and display the contours (Fig. 2.13).

9. To save the graphics, choose Save Plot As from the File menu and specify a plot format and
file name in the Save Plot As dialog box (Fig. 2.14).

10. Choose Leave Editor from the File menu or click the Leave Editor icon  and click Yes
to save changes to Recycle.

Using the above procedure, you can generate contour maps of your input data, results data, or
any data saved as an ASCII Matrix file of the same dimensions. For example, you can create a
contour map of the initial heads or you can use the Result Extractor to read the concentration
distribution from a transport simulation and display the corresponding contours. You may also
generate contour maps of the fields created by the Field Interpolator or Field Generator. See
chapter 5 for details about the Field Interpolator and Field Generator.
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Fig. 2.13 A contour map of the calculated hydraulic heads

Fig. 2.12 The Environment Options dialog box

Fig. 2.11 The Load Matrix dialog box
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Fig. 2.14 The Save Plot As dialog box for saving graphics in different formats

Fig. 2.15 The Search and Modify dialog box for creating solid fill plots

<< To create solid fill plots
1. Choose Recycle from the Tools menu

Note that data specified in Recycle will not be used by any simulation programs. We can use
Recycle to save temporary data or to display simulation results graphically.

2. Repeat steps 2 through 5 of the previous procedure to load H1.DAT into the model grid.
Skip these steps, if the data were saved in the previous procedure. 

3. Choose Search and Modify from the Value menu.
The Search and Modify dialog box appears (Fig. 2.15). If a row of the table is active,
model cells with values located between the Minimum and Maximum values will be filled
with the user-specified Color. 

4. Set the first 10 rows to active by clicking on cells of the Active-column. 
A row is active, if Active is set to Yes.

5. To assign colors to the active rows, click Spectrum.
The Color Spectrum dialog box appears (Fig. 2.16). 

6. In the Color Spectrum dialog box, click on the Minimum button and select a color. Click
on the Maximum button and select a color. Click OK, when finished.

7. To set the search ranges, click Level.
The Search Level dialog box appears (Fig. 2.17). 

8. In the Search Level dialog box, type 8 and 9 in the Minimum and Maximum edit fields.
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Fig. 2.16 The Color Spectrum dialog box for assigning colors

Fig. 2.17 The Search Level dialog box

Fig. 2.18 Solid fill plot with contour lines

Click OK when ready.
9. In the Search And Modify dialog box, click OK.

ASMWIN redraws the model and fills colors to cells.

You can overlay contours on the solid fill plot by doing the following 
1. Choose Environment from the Options menu, check the Visible check box, then click OK.
2. Choose Search and Modify from the Value menu, then Click OK.

Fig. 2.18 shows a solid fill plot with contour lines
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Fig. 2.19 The sample model loaded in ASMPATH

<< To calculate the capture zone of the pumping well
1. Choose Pathlines from the Run menu.

ASMWIN calls the particle tracking model ASMPATH and the current model will be loaded
into ASMPATH automatically. 

Note that if you subsequently modify and calculate a model within ASMWIN, you must load the
modified model into ASMPATH again to ensure that the modifications can be recognized by

ASMPATH. To load a model, click  and select a model file with the extension ASM from the
Open Model dialog box.

2. To calculate the capture zone of the pumping well: 

a. Click the Set Particles button  
b. Move the mouse cursor to the model area. The mouse cursor turns into crosshairs.
c. Point the crosshairs at the upper-left corner of the pumping well, as shown in Fig. 2.19.
d. Drag the crosshairs until the window covers the pumping well.
e. Release the mouse button.

The Particle Placement dialog box appears. Assign the numbers of particles to the edit
fields in the dialog box as shown in Fig. 2.20. When finished, click OK.

f. Click  to start the backward particle tracking.
ASMPATH calculates and shows the projections of the pathlines as well as the capture
zone of the pumping well (Fig. 2.21).

ASMPATH allows you to create time-related capture zones or isochrons of pumping wells. The
100-days-capture zone or 100-days-isochron shown in Fig. 2.23 is created by putting particles
around the pumping well, using the settings in the Particle Tracking Options dialog box as

shown in Fig. 2.22, and clicking . 
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Fig. 2.21 The capture zone of the pumping well

Fig. 2.20 The Particle Placement dialog box
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Fig. 2.23 100-days-capture zone calculated by ASMPATH

Fig. 2.22 The Particle tracking options dialog box
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2.2 Simulation of Solute Transport 
To demonstrate the use of the transport models, we assume that the pollutant is dissolved into
groundwater at a rate of 1 × 10  µg/s/m . The longitudinal and transverse dispersivities of the-4 2

aquifer are 10 m and 1 m, respectively. The retardation factor is 2. The initial concentration,
molecular diffusion coefficient, and decay rate are assumed to be zero. 

The breakthrough curves (concentration versus time) at the cells [15, 15], [20, 15] and [25, 15]
and the concentration distribution after 2.5 years should be calculated. 

Transport models are based on the calculated flow field. Before going to the next step, make
sure that the flow simulation has been performed.

2.2.1 Perform the transport simulation with ASMT2SIM
Prior to running ASMT2SIM, you have to specify the basic boundary conditions of the transport
model, the observation points and the initial concentration. Similar to the flow model, you
specify a code for each model cell which indicates whether (1) solute concentration varies with
time (active concentration cell), (2) the concentration is kept fixed at a constant value (constant-
concentration cell), or (3) the cell is an inactive concentration cell. Use 1 for an active
concentration cell, -1 for a constant-concentration cell, and 0 for an inactive concentration cell.
Active, variable-head cells can be treated as inactive concentration cells to minimize the area
needed for transport simulation, as long as the solute concentration is insignificant near those
cells.

<< To assign the boundary condition to the finite difference transport model
1. Choose Boundary Conditions << Transport Model from the Grid menu.

ASMWIN shows the model grid. The default value for all cells is 1.

2. Choose Leave Editor from the File menu or click the Leave Editor icon 

<< To define observation points
1. Choose Observation Points from the Grid menu.

ASMWIN shows the model grid. An observation point is indicated by the cell value 1. 
2. Assign 1 to the cells [15, 15], [20, 15] and [25, 15]. 

3. Choose Leave Editor from the File menu or click the Leave Editor icon 

<< To set the initial concentration 
1. Choose FD-Transport << Initial Concentration from the Parameters menu.

The default value for all cells is 0.

2. Choose Leave Editor from the File menu or click the Leave Editor icon 

<< To assign the input rate of contaminants
1. Choose FD-Transport << Input rate of contaminants from the Parameters menu.

ASMWIN displays the model grid.
2. Assign 0.04 [µg/s] to the cells within the contaminated area. 

This value is the input rate of contaminants for each cell. Since the area of each cell is 400
[m ] and the dissolution rate is 1 × 10  [µg/s/m ], the input rate of the pollutant to the2 -4 2
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Fig. 2.24 The Transport - Finite Difference dialog box

aquifer is equal to 400 [m ] @ 1 × 10  [µg/s/m ] = 0.04 [µg/s].2 -4 2

<< To perform the transport simulation
1. Choose Transport << Finite Difference from the Run Menu.

The Transport - Finite Difference dialog box appears (Fig. 2. 24). It allows the user to
specify the necessary parameters and the simulation time. 

2. Click OK to start the transport simulation.
Prior to running the transport simulation, ASMWIN will use user-specified data to generate
an input file for the module ASMT2SIM.EXE.  In addition, ASMWIN creates a batch file
ASMTRPT.BAT in the model directory. After having generated these files, ASMWIN
automatically opens a DOS-box and runs ASMTRPT.BAT in the box.

<< Check simulation results and produce output
If a simulation is successfully completed, ASMT2SIM saves the calculated concentration
distribution in the file path\filename.cxy and the concentration versus time data in the file
path\filename.cvt. Where path is the directory in which your model data are saved and filename
is the name of your model. 

Based on the result files, ASMWIN can generate contour maps or concentration versus time
curves. 

<< To generate contour maps of the calculated concentration
1. Choose Recycle from the Tools menu

Data specified in Recycle will not be used by any simulation program. We can use Recycle
to save temporary data or to display simulation results graphically.

2. Choose Result Extractor from the Value menu. 
3. Choose Concentration from the Result Type drop-down box. 
4. Click Read.

The calculated concontration will be read and put into the spreadsheet.
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Fig. 2.25 A contour map of the calculated concentration

5. Click Apply & Close. 
The data is applied to the Recycle matrix.

6. Choose Environment from the Options menu (or Press Ctrl+E). 
The Environment Options dialog box appears.

7. In the Environment Options dialog box, check the Visible check box of the Contours
group, click the color button next to the Visible check box to select an appearance color of
the contours. Note that ASMWIN will uncheck the Visible check box when you leave the
Editor.

8.. In the Environment Options dialog box, Click OK.
ASMWIN will redraw the model and display the contours (Fig. 2.25).

9. Choose Leave Editor from the File menu or click the Leave Editor icon  and click Yes
to save changes to Recycle.

<< To generate concentration versus time curves
1. Choose Graphs << Concentration - Time (FD) from the Tools Menu.

The Graph Viewer (see section 5.6) will be loaded and the concentration-time curves at the
observation points will be displayed (Fig. 2.26). 

2. Click Close to leave the Graph Viewer.
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Fig. 2.26 The Graph Viewer showing concentration-time curves

2.2.2 Perform a random walk transport simulation with ASMWALK
To start ASMWALK, choose Transport << Random Walk from the Run menu. ASMWIN calls
the Random Walk transport model ASMWALK and the current model will be loaded into
ASMWALK automatically. 

Note that if you subsequently modify and calculate a model within ASMWIN, you must load the
modified model into ASMWALK again to ensure that any modifications are recognized by ASMWALK.

To load a model, click  and select a model file with the extension ASM from the Open Model dialog
box.

The Random Walk method requires time parameters, transport paramters and the initial
distribution of particles. A fixed mass (or mass injection rate) is assigned to each particle. The
sum over all particle masses (or injection rates) constitutes the total amount of pollutant injected
into the aquifer.
 
<< To assign time parameters
1. Choose Time Parameters & Velocity from the Options menu.

The Time Parameters and Velocity Interpolation dialog box appears (Fig. 2.27).  
2. Select Seconds as the time unit. Set Step Length to 1314900 s and Max. Steps to 60. 
3. Select Permanent mass injection type.
4. Click OK to close the dialog box.

<< To specify transport parameters and initial distribution of particles
1. Move the mouse cursor to the model area. The mouse cursor turns into a crosshairs.
2. Place the crosshairs at the upper-left corner of the contaminated area. 
3. Drag the crosshairs until the window covers the contaminated area then release the mouse

button.
The Particle and Transport Parameters dialog box appears (Fig. 2.28). 
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Fig. 2.27 The Time Parameters and Velocity Interpolation dialog box

Fig. 2.28 The Particle and Transport Parameters dialog box

4. Assign the numbers of particles to the edit fields in the dialog box as shown in the figure.
When finished, click OK. 
ASMWALK assigns 16 (= 4 × 4) particles to each cell within the contaminated area. Each
particle has a mass injection rate of 0.0025 [µg/s]. This yields an injection rate of 0.04 [µg/s]
for each cell.

<< To perform the transport simulation
C Click  to start the transport simulation. 

ASMWALK shows the position of the particles and calculates the concentration in each cell
for each transport step. The step number and total elapsed time are shown in the tool bar.
The simulation stops when the maximum number of transport steps is reached or when all

particles have been removed by sinks. If you click , the simulation will be stopped at the
end of the current transport step. 
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Fig. 2.29 The Environment Options dialog box

Fig. 2.30 A contour map of the calculated concentration

<< To generate contour maps of the calculated concentration
1. Choose Environment from the Options menu. 

The Environment Options dialog box appears (Fig. 2.29)
2. Check the Visible check box of the Contours group and select the option conc. You can

specify the format and size of the contour labels, see Sec. 4.1.3 for details.
3. Click OK.

ASMWALK will then redraw the model and display the final position of the particles and
the concentration contours (Fig. 2.30).
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Fig. 2.31 The Graph Viewer showing concentration-time curves

<< To generate concentration versus time curves
1. Choose Concentration-Time Curves << Display from the Options Menu.

The Graph Viewer appears and shows the curves (Fig. 2.31).
2. Click Close to leave the Graph Viewer.
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Fig. 2.32 The Reset Matrix dialog box

2.3 Automatic Calibration
In ASMWIN, the conductivities (transmissivities or hydraulic conductivities) or the fluxes
(boundary fluxes, groundwater recharge from precipitation and leakage fluxes) in a steady-state
flow model can be adjusted by automatic calibration module (ASMOPTI). To demonstrate the
use of this module, we assume that the hydraulic conductivity of the entire model is
homogeneous but its value is unknown. We want to calibrate this value. There are four
observation points with the coordinates and the observed hydraulic heads listed below.

Observation X-coordinate Y-coordinate Hydraulic head
P1 130 200 8.778
P2 200 400 8.662
P3 480 250 8.124
P4 460 450 8.195

Three steps are required for an automatic calibration:
1. Assign the zonal structure of each parameter.

Automatic calibration requires a subdivision of the model domain into a small number of
reasonable zones of equal parameter values. The zonal structure is given by assigning to
each zone a parameter number in the Data Editor. 

2. Specify the starting values for each parameter.
3. Specify the observation points and the measured hydraulic heads.

<< To assign the zonal structure to hydraulic conductivity
1. Choose Hydraulic Conductivity from the Parameters Menu.
2. Choose Matrix<<Reset from the Value menu (or press Ctrl+R).

The Reset Matrix dialog box appears (Fig. 2.32).
3. Type 1 in the Parameter Number edit box, then click OK.

The entire model is set to parameter 1. 

Note that ASMOPTI does not use the specified value for Hydraulic Conductivity of this dialog box. Instead,
ASMOPTI uses the starting value of each parameter as given in the Parameter List dialog box (see below)
which subsequently is varied iteratively in order to obtain the optimal value yielding the best fit of observed
head data.

4. Choose Leave Editor from the File menu or click the Leave Editor icon 
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Fig. 2.33 The Reset Matrix dialog box

<< To specify starting values for the each parameter
1. Choose Calibration<<Parameter List from the Parameters menu (choose Parameter List

from the Value menu, if you are in the Data Editor).
The Parameter List dialog box appears (Fig. 2.33). 

2. Make the first parameter active by clicking on the cell of the Active-column.
A parameter will be automatically calibrated, if Active is set to Yes.

3. Assign an initial value (e.g., 0.0001 m/s) and the lower and upper bounds to the parameter.
The option for constraining the fit parameters can be switched on using Use upper and
lower bounds. It is suggested to look for an unconstrained solution first.

4. If you are in the Data Editor, choose Leave Editor from the File menu or click the Leave

Editor icon 

<< To specify the observation points and the measured hydraulic heads
1. Choose Calibration<<Bores and Measurements from the Parameters menu.

The Bores and Measurements dialog box appears (Fig. 2.34).
2. Set the first four boreholes to active by clicking on the cell of the Active-column.

The measured hydraulic head of a borehole will be used for the automatic calibration, if
Active is set to Yes.

3. Assign the measured heads and x- and y-coordinates to each borehole.
4. Click OK to close the dialog box.
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Fig. 2.34 The Bores and Measurements dialog box

Fig. 2.35 The Calibration dialog box

<< To Perform the Automatic Calibration
1. Choose Calibration from the Run menu.

The Calibration dialog box appears (Fig. 2.35). It allows the user to specify the
convergence criteria for the iterative equation solver and the optimization parameters for the
Marquardt-Levenberg algorithm.

2. Click OK to start the calibration.
Prior to running the automatic calibration, ASMWIN will use user-specified data to generate
a main input file, a zone-identification file (which describes the zonal structure)  and an
observation file (which contains the measurement points and measured values) for
ASMOPTI. In addition, ASMWIN generates a batch file ASMOPTI.BAT in the model data
directory. After having generated these files, ASMWIN automatically opens a DOS-box and
runs ASMOPTI.BAT in the box.
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<< Check Calibration Results 
During the automatic calibration several result files are created. The file with extension .PRF
records the single steps of parameter optimization and the optimization results (Table 2.2). The
file with extension .1 contains the result of the final flow simulation. It has the same form as the
result file in a flow simulation without optimization with the difference that now the flow
simulation is based on the optimized parameters.  

 ---------------------------------------------------

               OPTIMIZATION RESULTS

---------------------------------------------------

Optimized parameters:
---------------------------------------------------
Hydraulic conductivity [L/SEC.]:  1 Zone(s)
Zone   1  Parameter No.=   1  Value= 5.04360E-04

Comparison:
Observation      Observed    Calculated  Residual
Name             value       value               
---------------------------------------------------
1                 8.788000    8.788355   -0.000355
2                 8.662000    8.662092   -0.000092
3                 8.124000    8.125015   -0.001015
4                 8.195000    8.195501   -0.000501

Statistics:
---------------------------------------------------
No. of optimization iterations:              5
Criterion for convergence:            0.000500
Mean squared deviations:              0.000000
Sum of squared deviations:            0.000001
Lambda:                               0.000320
Max. deviation:                      -0.000092     2         
Min. deviation:                      -0.001015     3         
Mean deviation:                      -0.000491

Table 2.2 A part of the optimization result file .PRF

You can create a scatter diagram to present the calibration result. The observed head values are
plotted on one axis against the corresponding calculated values on the other.

<< To create a scatter diagram
C Choose Graphs<<Scatter Diagram (Calibration) from the Tools menu.

ASMWIN shows the scatter diagram (Fig. 2.36). See Sec. 5.6 for details about the use of
this dialog box.

Choosing Recycle from the Tools menu, you can create a plot showing the observed heads and
calculated heads at the observation boreholes (Fig. 2.37).
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Fig. 2.37 The Recycle tool showing the observed and calculated heads
at the boreholes.

Fig. 2.36 The Graph Viewer showing a scatter diagram


